summary refs log tree commit diff
diff options
context:
space:
mode:
authorZheng junjie <873216071@qq.com>2021-04-28 00:12:33 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-26 15:20:06 +0200
commitefff3fd87921b27d536c622410fab2255e5b5457 (patch)
tree516b2102b8de268b3f3e83acef318a63a29951bc
parentcba634e56cc8acb7d48aec7ea65cd6244099f9db (diff)
downloadguix-efff3fd87921b27d536c622410fab2255e5b5457.tar.gz
gnu: Add zoxide.
* gnu/packages/rust-apps.scm (zoxide): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/rust-apps.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index d31f95ca05..c75d431c04 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -802,3 +802,40 @@ the details of how it was triggered.
 library and a dynamic library, and a C header to be used by any C (and
 C-compatible) software.")
     (license license:expat)))
+
+(define-public zoxide
+  (package
+    (name "zoxide")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "zoxide" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1ih01l3xp8plicxhmyxjkq12ncpdb8954jcj3dh3lwvkhvw29nkk"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-anyhow" ,rust-anyhow-1)
+        ("rust-askama" ,rust-askama-0.10)
+        ("rust-bincode" ,rust-bincode-1)
+        ("rust-clap" ,rust-clap-3)
+        ("rust-dirs-next" ,rust-dirs-next-2)
+        ("rust-dunce" ,rust-dunce-1)
+        ("rust-glob" ,rust-glob-0.3)
+        ("rust-once-cell" ,rust-once-cell-1)
+        ("rust-ordered-float" ,rust-ordered-float-2)
+        ("rust-rand" ,rust-rand-0.7)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-tempfile" ,rust-tempfile-3))
+       #:cargo-development-inputs
+       (("rust-assert-cmd" ,rust-assert-cmd-1)
+        ("rust-seq-macro" ,rust-seq-macro-0.2))))
+    (home-page "https://github.com/ajeetdsouza/zoxide/")
+    (synopsis "Fast way to navigate your filesystem")
+    (description
+     "Zoxide is a fast replacement for your @command{cd} command. It keeps
+track of the directories you use most frequently, and uses a ranking algorithm
+to navigate to the best match.")
+    (license license:expat)))