summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-02-21 17:32:14 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-02-27 11:29:03 +0100
commitf6a151cdc620b037fed1b899ad40a073111786e3 (patch)
tree74380582073d9e65cdce1139578bde29110843d7
parentfdd481354705d8f7ec64f0383ecdfee587fb7a71 (diff)
downloadguix-f6a151cdc620b037fed1b899ad40a073111786e3.tar.gz
gnu: gnome-shell-extension-appindicator: Use the copy-build-system.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-appindicator):
Use the copy-build-system.
-rw-r--r--gnu/packages/gnome-xyz.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index a3074288de..87830194fd 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -136,19 +136,11 @@ the Obsidian icon theme.")
                (base32
                 "1fjhx23jqwv3d0smwhnjvc35gqhwk9p5f96ic22pfax653cn5vh8"))
               (file-name (git-file-name name version))))
-    (build-system trivial-build-system)
+    (build-system copy-build-system)
     (arguments
-     '(#:modules ((guix build utils))
-       #:builder
-       (begin
-         (use-modules (guix build utils))
-         (let* ((source (assoc-ref %build-inputs "source"))
-                (install-dir (string-append (assoc-ref %outputs "out")
-                                            "/share/gnome-shell/extensions"
-                                            "/appindicatorsupport@rgcjonas.gmail.com")))
-           (mkdir-p install-dir)
-           (copy-recursively source install-dir)
-           #t))))
+     `(#:install-plan
+       '(("." ,(string-append "share/gnome-shell/extensions/"
+                              "appindicatorsupport@rgcjonas.gmail.com")))))
     (synopsis "Adds KStatusNotifierItem support to GNOME Shell")
     (description "This extension integrates Ubuntu AppIndicators
 and KStatusNotifierItems (KDE's successor of the systray) into