summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-04 14:52:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-04 22:38:12 +0100
commit0d66b9d6cd6894a82871468f0c14071a34def0f2 (patch)
tree8a5d43bb962e0a558dd64ba12237be923684baea
parent3cc6b1232bc5aab709f429100be7b5fc72c17a67 (diff)
downloadguix-0d66b9d6cd6894a82871468f0c14071a34def0f2.tar.gz
gnu: Add opencog.
* gnu/packages/opencog.scm (opencog): New variable.
-rw-r--r--gnu/packages/opencog.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/opencog.scm b/gnu/packages/opencog.scm
index 4cde45d9ab..f9551a8e9f 100644
--- a/gnu/packages/opencog.scm
+++ b/gnu/packages/opencog.scm
@@ -22,6 +22,8 @@
   #:use-module (gnu packages check)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages guile)
+  #:use-module (gnu packages language)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
@@ -197,3 +199,54 @@ OpenCog framework.")
 control the application of processing and memory resources to specific
 tasks.")
       (license license:agpl3))))
+
+(define-public opencog
+  ;; There are no recent releases.
+  (let ((commit "ceac90507610cb2d0ee98f97a2086865292b1204")
+        (revision "1"))
+    (package
+      (name "opencog")
+      (version (git-version "0.1.4" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/opencog/opencog.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1j8wv910fvrmph370wv5pv2f4bc2s9vl6i7bw3pkmwbdhxkhjbhm"))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:test-target "tests"
+         #:configure-flags
+         (list
+          (string-append "-DGUILE_INCLUDE_DIR="
+                         (assoc-ref %build-inputs "guile")
+                         "/include/guile/2.2/")
+          (string-append "-DGUILE_SITE_DIR="
+                         (assoc-ref %outputs "out")
+                         "/share/guile/site/2.2/"))))
+      (inputs
+       `(("attention" ,attention)
+         ("atomspace" ,atomspace)
+         ("boost" ,boost)
+         ("cogserver" ,cogserver)
+         ("cogutil" ,cogutil)
+         ("gmp" ,gmp)
+         ("guile" ,guile-2.2)
+         ("libuuid" ,util-linux)
+         ("link-grammar" ,link-grammar)))
+      (native-inputs
+       `(("cxxtest" ,cxxtest)
+         ("python" ,python-minimal)
+         ("pkg-config" ,pkg-config)))
+      (home-page "https://github.com/opencog/attention/")
+      (synopsis "Framework for integrated artificial intelligence")
+      (description "OpenCog is a framework for developing AI systems,
+especially appropriate for integrative multi-algorithm systems, and artificial
+general intelligence systems.  It currently contains a functional core
+framework, and a number of cognitive agents at varying levels of completion,
+some already displaying interesting and useful functionalities alone and in
+combination.")
+      (license license:agpl3))))