summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-04 02:33:36 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-04 05:39:00 +0100
commit0f97e0af40aa5ef91b9d9e411a67ad0c69100cbd (patch)
tree5c963abb7a7778732e1f0b56ca61f7a85fca2909
parent897ce1c81f6d958e16eef5c2f366303e6eea974b (diff)
downloadguix-0f97e0af40aa5ef91b9d9e411a67ad0c69100cbd.tar.gz
gnu: rinutils: Use G-expressions.
* gnu/packages/games.scm (rinutils)[arguments]:
Rewrite as G-expressions.  Rename misnamed 'fix-build-env.
[native-inputs]: Remove input labels.  Remove shlomif-cmake-modules.
-rw-r--r--gnu/packages/games.scm60
1 files changed, 29 insertions, 31 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d8c7ab6397..e9c3d8b8c5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7519,16 +7519,35 @@ original.")
               (sha256
                (base32
                 "1fpxyg86ggv0h7j8aarjjxrvwlj7jycd3bw066c0dwkq2fszxsf2"))))
-    (native-inputs
-     `(("perl" ,perl)
-       ;; The following is only needed for tests.
-       ("perl-file-find-object" ,perl-file-find-object)
-       ("perl-test-differences" ,perl-test-differences)
-       ("perl-class-xsaccessor" ,perl-class-xsaccessor)
-       ("perl-io-all" ,perl-io-all)
-       ("perl-test-runvalgrind" ,perl-test-runvalgrind)
-       ("cmake-rules" ,shlomif-cmake-modules)
-       ("pkg-config" ,pkg-config)))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'copy-cmake-modules
+                 (lambda _
+                   (copy-file #$shlomif-cmake-modules
+                              (string-append "cmake/"
+                                             (strip-store-file-name
+                                              #$shlomif-cmake-modules)))))
+               (replace 'check
+                 (lambda _
+                   (with-directory-excursion "../source"
+                     (setenv "FCS_TEST_BUILD" "1")
+                     (setenv "RINUTILS_TEST_BUILD" "1")
+                     ;; TODO: Run tests after setting RINUTILS_TEST_TIDY to `1',
+                     ;; which requires tidy-all.
+                     ;; (setenv "RINUTILS_TEST_TIDY" "1")
+                     (invoke "perl"
+                             "CI-testing/continuous-integration-testing.pl")))))))
+    (native-inputs
+     (list perl
+           ;; The following are needed only for tests.
+           perl-class-xsaccessor
+           perl-file-find-object
+           perl-io-all
+           perl-test-differences
+           perl-test-runvalgrind
+           pkg-config))
     (inputs
      (list cmocka
            perl-env-path
@@ -7540,27 +7559,6 @@ original.")
            perl-text-glob
            perl-number-compare
            perl-moo))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-build-env
-           (lambda* (#:key inputs #:allow-other-keys)
-             (use-modules (guix build utils))
-             (let* ((cmake-rules (assoc-ref inputs "cmake-rules")))
-               (copy-file cmake-rules
-                          (string-append "cmake/"
-                                         (strip-store-file-name cmake-rules)))
-               #t)))
-         (replace 'check
-           (lambda _
-             (with-directory-excursion "../source"
-               (setenv "FCS_TEST_BUILD" "1")
-               (setenv "RINUTILS_TEST_BUILD" "1")
-               ;; TODO: Run tests after setting RINUTILS_TEST_TIDY to `1',
-               ;; which requires tidy-all.
-               ;; (setenv "RINUTILS_TEST_TIDY" "1")
-               (invoke "perl" "CI-testing/continuous-integration-testing.pl")))))))
-    (build-system cmake-build-system)
     (home-page "https://www.shlomifish.org/open-source/projects/")
     (synopsis "C11 / gnu11 utilities C library")
     (description "This package provides C11 / gnu11 utilities C library")