summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2021-02-11 22:03:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-11 22:29:37 +0100
commit160e4a95e7ef0880939afca7d0af4c9b5596bc6b (patch)
treef4948fcba23e17f6d64f70d3f53d84646b0327c4
parent175bea0ca42dba3e02109820efae0cac2804e73b (diff)
downloadguix-160e4a95e7ef0880939afca7d0af4c9b5596bc6b.tar.gz
gnu: bowtie1: Update to 1.3.0.
* gnu/packages/bioinformatics.scm (bowtie1): Update to 1.3.0.
[arguments]: Set CC in make flags.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioinformatics.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1a0e72ac4a..6f835b3875 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1654,14 +1654,14 @@ gapped, local, and paired-end alignment modes.")
 (define-public bowtie1
   (package
     (name "bowtie1")
-    (version "1.2.3")
+    (version "1.3.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/bowtie-bio/bowtie/"
-                                  version "/bowtie-src-x86_64.zip"))
+                                  version "/bowtie-" version "-src.zip"))
               (sha256
                (base32
-                "0vmiqdhc9dzyfy9sh6vgi7k9xy2hiw8g87vbamnc6cgpm179zsa4"))
+                "11dbihdnrizc6qhx9xsw77w3q5ssx642alaqzvhxx32ak9glvq04"))
               (modules '((guix build utils)))
               (snippet
                '(substitute* "Makefile"
@@ -1672,7 +1672,7 @@ gapped, local, and paired-end alignment modes.")
     (arguments
      '(#:tests? #f                      ; no "check" target
        #:make-flags
-       (list "all"
+       (list "CC=gcc" "all"
              (string-append "prefix=" (assoc-ref %outputs "out")))
        #:phases
        (modify-phases %standard-phases