summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-17 22:15:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-17 22:15:59 +0300
commit3645f7aa0c4f0cb89721dfb06992bfba89735e3b (patch)
treeccf4d00c9833244f9693d18d1906b214ee6f21a9
parente70eb6dd3fda4620225899b80e6ac8beea19592f (diff)
downloadguix-3645f7aa0c4f0cb89721dfb06992bfba89735e3b.tar.gz
gnu: lagrange: Update to 1.7.2.
* gnu/packages/web-browsers.scm (lagrange): Update to 1.7.2.
[inputs]: Add fribidi, harfbuzz, libwebp.
-rw-r--r--gnu/packages/web-browsers.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 8cd75e7a08..89eb61007f 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -59,6 +59,7 @@
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages fonts)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages fribidi)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
@@ -697,7 +698,7 @@ key-bindings (Emacs, vi, CUA), and is fully configurable in Common Lisp.")
 (define-public lagrange
   (package
     (name "lagrange")
-    (version "1.5.2")
+    (version "1.7.2")
     (source
      (origin
        (method url-fetch)
@@ -705,7 +706,7 @@ key-bindings (Emacs, vi, CUA), and is fully configurable in Common Lisp.")
         (string-append "https://git.skyjake.fi/skyjake/lagrange/releases/"
                        "download/v" version "/lagrange-" version ".tar.gz"))
        (sha256
-        (base32 "0gqaipgs16kw711ijhshmbhhvlyjvh37wxdz059p4vvjhfrxbr1v"))))
+        (base32 "1fr7p0pjli9clsgr0a1fp1pr119r9zqx43dvhc1g91bj742mxhfa"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #false                  ;no tests
@@ -713,7 +714,10 @@ key-bindings (Emacs, vi, CUA), and is fully configurable in Common Lisp.")
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("libunistring" ,libunistring)
+     `(("fribidi" ,fribidi)
+       ("harfbuzz" ,harfbuzz)
+       ("libunistring" ,libunistring)
+       ("libwebp" ,libwebp)
        ("mpg123" ,mpg123)
        ("openssl" ,openssl)
        ("pcre" ,pcre)