summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-02-22 22:20:40 +1100
committerLeo Famulari <leo@famulari.name>2021-04-09 16:09:24 -0400
commit586f017d9800a23c71b347c74aee5017a168b35b (patch)
treeb1aa25231559037c54555b77aba5d502c5f94aad
parent8effa05378977a2dc7ee86dd719fa1f4754658bf (diff)
downloadguix-586f017d9800a23c71b347c74aee5017a168b35b.tar.gz
gnu: python-pyqt: Fix build for new python-sip.
* gnu/packages/qt.scm (python-pyqt)
[source]: Remove pyqt-public-sip.patch.
[propagated-inputs]: Add python-pyqt5-sip.
* gnu/packages/patches/pyqt-public-sip.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/pyqt-public-sip.patch55
-rw-r--r--gnu/packages/qt.scm8
3 files changed, 4 insertions, 60 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 075504e302..8365e19b02 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1559,7 +1559,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/pybugz-stty.patch			\
   %D%/packages/patches/pygpgme-disable-problematic-tests.patch  \
   %D%/packages/patches/pyqt-configure.patch			\
-  %D%/packages/patches/pyqt-public-sip.patch			\
   %D%/packages/patches/python-2-deterministic-build-info.patch	\
   %D%/packages/patches/python-2.7-adjust-tests.patch		\
   %D%/packages/patches/python-2.7-search-paths.patch		\
diff --git a/gnu/packages/patches/pyqt-public-sip.patch b/gnu/packages/patches/pyqt-public-sip.patch
deleted file mode 100644
index 44cdcb6371..0000000000
--- a/gnu/packages/patches/pyqt-public-sip.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-https://sources.debian.org/data/main/p/pyqt5/5.11.3+dfsg-1/debian/patches/public_sip.diff
-
-From: Dmitry Shachnev <mitya57@debian.org>
-Date: Tue, 3 Jul 2018 09:46:42 +0300
-Subject: Use the public version of sip module
-
-Per https://www.debian.org/doc/debian-policy/#convenience-copies-of-code.
----
- configure.py              | 2 +-
- designer/pluginloader.cpp | 2 +-
- qmlscene/pluginloader.cpp | 4 ++--
- 3 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/configure.py b/configure.py
-index 32d03a0..3c43a14 100644
---- a/configure.py
-+++ b/configure.py
-@@ -2440,7 +2440,7 @@ def get_sip_flags(target_config):
-     the target configuration.
-     """
- 
--    sip_flags = ['-n', 'PyQt5.sip']
-+    sip_flags = ['-n', 'sip']
- 
-     # If we don't check for signed interpreters, we exclude the 'VendorID'
-     # feature
-diff --git a/designer/pluginloader.cpp b/designer/pluginloader.cpp
-index f41d391..3ca8b11 100644
---- a/designer/pluginloader.cpp
-+++ b/designer/pluginloader.cpp
-@@ -167,7 +167,7 @@ bool PyCustomWidgets::importPlugins(const QString &dir, const QStringList &plugi
-     // Make sure we have sip.unwrapinstance.
-     if (!sip_unwrapinstance)
-     {
--        sip_unwrapinstance = getModuleAttr("PyQt5.sip", "unwrapinstance");
-+        sip_unwrapinstance = getModuleAttr("sip", "unwrapinstance");
- 
-         if (!sip_unwrapinstance)
-             return true;
-diff --git a/qmlscene/pluginloader.cpp b/qmlscene/pluginloader.cpp
-index e14b946..140e80c 100644
---- a/qmlscene/pluginloader.cpp
-+++ b/qmlscene/pluginloader.cpp
-@@ -412,9 +412,9 @@ PyObject *PyQt5QmlPlugin::getModuleAttr(const char *module, const char *attr)
- void PyQt5QmlPlugin::getSipAPI()
- {
- #if defined(SIP_USE_PYCAPSULE)
--    sip = (const sipAPIDef *)PyCapsule_Import("PyQt5.sip._C_API", 0);
-+    sip = (const sipAPIDef *)PyCapsule_Import("sip._C_API", 0);
- #else
--    PyObject *c_api = getModuleAttr("PyQt5.sip", "_C_API");
-+    PyObject *c_api = getModuleAttr("sip", "_C_API");
- 
-     if (c_api)
-     {
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d604a9ccb3..530fcf1039 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1903,17 +1903,17 @@ module provides support functions to the automatically generated code.")
                    (string-append "https://www.riverbankcomputing.com/static/"
                                   "Downloads/PyQt5/" version "/PyQt5-"
                                   version ".tar.gz")))
-        (file-name (string-append "PyQt5-"version ".tar.gz"))
+        (file-name (string-append "PyQt5-" version ".tar.gz"))
         (sha256
          (base32
           "1z74295i69cha52llsqffzhb5zz7qnbjc64h8qg21l91jgf0harp"))
-       (patches (search-patches "pyqt-configure.patch"
-                                "pyqt-public-sip.patch"))))
+        (patches (search-patches "pyqt-configure.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("qtbase" ,qtbase))) ; for qmake
     (propagated-inputs
-     `(("python-sip" ,python-sip)))
+     `(("python-sip" ,python-sip)
+       ("python-pyqt5-sip" ,python-pyqt5-sip)))
     (inputs
      `(("python" ,python-wrapper)
        ("qtbase" ,qtbase)