summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-10-27 17:43:39 +0100
committerChristopher Baines <mail@cbaines.net>2018-11-20 19:48:02 +0000
commit6cd1bbd0b16f97493ff4235f938ac81f4b2f8b92 (patch)
tree830289bc34dcf10e4657a485328c432a8f067859
parent9c98d588c2e20fe7434b4ad74c16abbbb28eeb88 (diff)
downloadguix-6cd1bbd0b16f97493ff4235f938ac81f4b2f8b92.tar.gz
gnu: Add python-django-pipeline.
* gnu/packages/django.scm (python-django-pipeline, python2-django-pipeline):
New variables.
-rw-r--r--gnu/packages/django.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index dea925e568..e476d7015c 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -518,6 +518,46 @@ project.")
 (define-public python2-django-overextends
   (package-with-python2 python-django-overextends))
 
+(define-public python-django-pipeline
+  (package
+    (name "python-django-pipeline")
+    (version "1.6.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "django-pipeline" version))
+       (sha256
+        (base32
+         "1a207y71r7za033ira0qmh2yrgp5rq0l04gw2fg9b8jri7sslrzg"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-source
+           (lambda _
+             (substitute* "tests/tests/test_compiler.py"
+               (("\\/usr\\/bin\\/env")
+                (which "env")))))
+         (replace 'check
+           (lambda*(#:key tests? #:allow-other-keys)
+             (or
+              (not tests?)
+              (begin
+                (setenv "DJANGO_SETTINGS_MODULE" "tests.settings")
+                (invoke "django-admin" "test" "tests"))))))))
+    (propagated-inputs
+     `(("python-django" ,python-django)
+       ("python-slimit" ,python-slimit)
+       ("python-jsmin" ,python-jsmin)))
+    (home-page
+     "https://github.com/jazzband/django-pipeline")
+    (synopsis "Asset packaging library for Django")
+    (description
+     "Pipeline is an asset packaging library for Django, providing both CSS
+and JavaScript concatenation and compression, built-in JavaScript template
+support, and optional data-URI image and font embedding.")
+    (license license:expat)))
+
 (define-public python-django-redis
   (package
     (name "python-django-redis")