summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-10 13:22:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-10 13:22:44 +0100
commit8b7e63a86655c315e01029611af99315c43c20ca (patch)
treeca913e3c6488f5cddc91f3282ea952494459e2c3
parent75aa88153fdbc1faeb23295f003d6bdd16aafa2b (diff)
downloadguix-8b7e63a86655c315e01029611af99315c43c20ca.tar.gz
gnu: Add texlive-lua-alt-getopt.
* gnu/packages/tex.scm (texlive-lua-alt-getopt): New variable.
-rw-r--r--gnu/packages/tex.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index eddf8f3ca4..929af1cd3d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3716,6 +3716,21 @@ this bundle for use independent of ConTeXt.")
     ;; GPL version 2 only
     (license license:gpl2)))
 
+(define-public texlive-lua-alt-getopt
+  (package
+    (inherit
+     (simple-texlive-package
+      "texlive-lua-alt-getopt"
+      (list "doc/support/lua-alt-getopt/" "scripts/lua-alt-getopt/")
+      (base32 "0cizxzn33n3pn98xkqnxb8s6vdwkar3xrwhraqrs05pjfdn9d4wz")
+      #:trivial? #t))
+    (home-page "https://ctan.org/support/lualibs/lua-alt-getopt")
+    (synopsis "Process application arguments the same way as getopt_long")
+    (description
+     "This package provides a Lua module for processing application arguments
+in the same way as BSD/GNU @code{getopt_long(3)} functions do.")
+    (license license:expat)))
+
 ;; TODO: We should be able to build this from the sources on Github with
 ;; texlive-l3build, but I haven't been able to get it to work.
 (define-public texlive-luaotfload