summary refs log tree commit diff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-09-02 19:33:18 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-09-03 07:46:59 +0200
commitabafdb2aacefef0a2ecf46c8b06b52343727f34f (patch)
tree3b37f4028a213571901b51c4fdaac0d72595533e
parentabd2fde8471855b2d48a9bd631755e6cd83921d9 (diff)
downloadguix-abafdb2aacefef0a2ecf46c8b06b52343727f34f.tar.gz
gnu: noisetorch: Update to 0.7.2-beta.
* gnu/packages/pulseaudio.scm (noisetorch): Update to 0.7.2-beta.
[arguments]: Add phase 'disable-update-check.go.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/pulseaudio.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 3757859d11..9522d023ad 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -538,7 +538,7 @@ The plugin is made to work with 1 or 2 channels (ladspa plugin),
 (define-public noisetorch
   (package
     (name "noisetorch")
-    (version "0.6.1-beta")
+    (version "0.7.2-beta")
     (source
      (origin
        (method git-fetch)
@@ -547,7 +547,7 @@ The plugin is made to work with 1 or 2 channels (ladspa plugin),
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1jmh7204mhlabdn0azfjrm3kb944j24n0w0cwibqrs9lfgdn8k52"))))
+        (base32 "06xlqjma8h7lcnqgc9226blps6m9dp487hk71lslfxj0jkay548k"))))
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/lawl/NoiseTorch"
@@ -572,6 +572,12 @@ The plugin is made to work with 1 or 2 channels (ladspa plugin),
                  (lambda ()
                    (format #t "package main~%~%var version=~s~&" ,version))))
              #t))
+         (add-after 'unpack 'disable-update-check.go
+           (lambda _
+             (with-directory-excursion "src/github.com/lawl/NoiseTorch"
+               (substitute* "main.go"
+                 ((".*updateCheck.*") "")))
+             #t))
          (add-before 'build 'go-generate
            (lambda _
              (with-directory-excursion "src/github.com/lawl/NoiseTorch"