summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-14 02:00:42 -0500
committerLeo Famulari <leo@famulari.name>2016-03-18 14:27:16 -0400
commitcedac813a58e6220edc771f112e0d50ab188b0ce (patch)
tree4f95a37c32dcc7a63b3dda71da532f8e10335439
parent3f7a182d25854d7a69cae8c98efcd55e72ac35fa (diff)
downloadguix-cedac813a58e6220edc771f112e0d50ab188b0ce.tar.gz
gnu: Add python-munkres.
* gnu/packages/python.scm (python-munkres, python2-munkres): New variables.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index af3c60bac9..aab239fe03 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8233,3 +8233,26 @@ way.")
     (inherit (package-with-python2
               (strip-python2-variant python-vobject)))
     (native-inputs `(("python2-setuptools" ,python2-setuptools)))))
+
+(define-public python-munkres
+  (package
+    (name "python-munkres")
+    (version "1.0.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "munkres" version))
+              (sha256
+               (base32
+                "1i6nf45i0kkzdx6k70giybsqxz4dxsjbrkrfqgjd7znfkf25sjik"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f)) ; no test suite
+    (home-page "http://software.clapper.org/munkres/")
+    (synopsis "Implementation of the Munkres algorithm")
+    (description "The Munkres module provides an implementation of the Munkres
+algorithm (also called the Hungarian algorithm or the Kuhn-Munkres algorithm),
+useful for solving the Assignment Problem.")
+    (license bsd-3)))
+
+(define-public python2-munkres
+  (package-with-python2 python-munkres))