summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-24 04:23:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-24 04:25:50 +0200
commit0e5d66abf6906d32a64dd8f9d8fce5c3ac743ff6 (patch)
treeeb1555f76404ba0019f1658c9c1991578d3752bb
parenta7b14a1b391fcd1365441da1298d425d520e7b57 (diff)
downloadguix-0e5d66abf6906d32a64dd8f9d8fce5c3ac743ff6.tar.gz
gnu: keepassxc: Update to 2.3.4.
* gnu/packages/password-utils.scm (keepassxc): Update to 2.3.4.
[arguments]: Remove obsolete ‘patch-sources’ phase.
-rw-r--r--gnu/packages/password-utils.scm22
1 files changed, 6 insertions, 16 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index b9653693c6..a63fd9bb36 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -100,7 +100,7 @@ human.")
 (define-public keepassxc
   (package
     (name "keepassxc")
-    (version "2.3.3")
+    (version "2.3.4")
     (source
      (origin
        (method url-fetch)
@@ -109,27 +109,17 @@ human.")
                            version "-src.tar.xz"))
        (sha256
         (base32
-         "1m8alsp39vk21zgcvy5zswk0dc1xmajbwnccg7n0lndsi7pqbzyg"))))
+         "02kq0a7a7hpw824n03apma00yq1c6dds224g15mrnnqqjn4af90c"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags '("-DWITH_XC_NETWORKING=YES"
                            "-DWITH_XC_BROWSER=YES"
-                           "-DWITH_XC_SSHAGENT=YES")
-       #:phases
-       (modify-phases %standard-phases
-         ;; should be fixed in 2.3.3+, see:
-         ;; https://github.com/keepassxreboot/keepassxc/pull/1964
-         (add-after 'unpack 'patch-sources
-           (lambda _
-             (substitute* "src/gui/entry/EditEntryWidget.cpp"
-               (("#include <QColorDialog>") "#include <QColorDialog>
-#include <QButtonGroup>"))
-             #t)))))
+                           "-DWITH_XC_SSHAGENT=YES")))
     (inputs
      `(("argon2" ,argon2)
-       ("curl" ,curl) ; XC_NETWORKING
+       ("curl" ,curl)                   ; XC_NETWORKING
        ("libgcrypt" ,libgcrypt)
-       ("libsodium" ,libsodium) ; XC_BROWSER
+       ("libsodium" ,libsodium)         ; XC_BROWSER
        ("libxi" ,libxi)
        ("libxtst" ,libxtst)
        ("qtbase" ,qtbase)
@@ -144,7 +134,7 @@ manage your passwords in a secure way.  You can put all your passwords in one
 database, which is locked with one master key or a key-file which can be stored
 on an external storage device.  The databases are encrypted using the
 algorithms AES or Twofish.")
-    ;; Non functional parts use various licences.
+    ;; Non-functional parts use various licences.
     (license license:gpl3)))
 
 (define-public keepassx