summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-07-18 18:52:43 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-07-18 18:52:49 +0300
commit262f904ebd2087a2f285b1c381ac32195c832c9e (patch)
treed782b0dc16b024d675f8bfd06f21bd7370ace89c
parent2fba90a8b27301ea6541d908732b7941ef6dce28 (diff)
downloadguix-262f904ebd2087a2f285b1c381ac32195c832c9e.tar.gz
gnu: i2pd: Rewrite 'check phase using with-directory-excursion.
* gnu/packages/i2p.scm (i2pd)[arguments]: In custom 'check phase use
with-directory-excursion to change directory.
-rw-r--r--gnu/packages/i2p.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/i2p.scm b/gnu/packages/i2p.scm
index 0f6aa2133a..075f1f403f 100644
--- a/gnu/packages/i2p.scm
+++ b/gnu/packages/i2p.scm
@@ -63,20 +63,18 @@
                                (make-flags '())
                                (parallel-tests? #t)
                                #:allow-other-keys)
-                       (let ((oldpwd (getcwd))
-                             (source (assoc-ref %build-inputs "source")))
+                       (let ((source (assoc-ref %build-inputs "source")))
                          (copy-recursively (string-append source "/tests")
                                            "./tests")
-                         (chdir "./tests")
-                         (substitute* "Makefile"
-                           (("../libi2pd/") (string-append source "/libi2pd/")))
-                         (apply invoke "make" "all"
-                                `(,@(if parallel-tests?
-                                        `("-j" ,(number->string
-                                                 (parallel-job-count)))
-                                        '())
-                                  ,@make-flags))
-                         (chdir oldpwd))))
+                         (with-directory-excursion "tests"
+                           (substitute* "Makefile"
+                             (("../libi2pd/") (string-append source "/libi2pd/")))
+                           (apply invoke "make" "all"
+                                  `(,@(if parallel-tests?
+                                          `("-j" ,(number->string
+                                                    (parallel-job-count)))
+                                          '())
+                                    ,@make-flags))))))
                    (add-after 'install 'install-headers
                      (lambda* (#:key outputs #:allow-other-keys)
                        (let* ((install-dir (assoc-ref outputs "out"))