summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-20 07:56:21 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:49 -0400
commit51c8370385173c1055595c2721b1e70137e7dbd7 (patch)
tree2ab3f69665969768cee97dc286daf5bfb7f82e66
parent522b61ab80ae9fd7696b452c99a16b5b026e8072 (diff)
downloadguix-51c8370385173c1055595c2721b1e70137e7dbd7.tar.gz
gnu: Add ghc-genvalidity-property.
* gnu/packages/haskell.scm (ghc-genvalidity-property): New variable.
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a9b0dd71ca..e2a7f20697 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11594,6 +11594,38 @@ stand for certain ASCII character sequences, i.e. → instead of @code{->},
 with the @code{Validity} typeclass.")
     (license license:expat)))
 
+(define-public ghc-genvalidity-property
+  (package
+    (name "ghc-genvalidity-property")
+    (version "0.2.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/"
+             "genvalidity-property/genvalidity-property-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0cjw5i2pydidda9bnp6x37ylhxdk9g874x5sadr6sscg5kq85a1b"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-genvalidity" ,ghc-genvalidity)
+       ("ghc-hspec" ,ghc-hspec)
+       ("hspec-discover" ,hspec-discover)
+       ("ghc-validity" ,ghc-validity)))
+    (native-inputs `(("ghc-doctest" ,ghc-doctest)))
+    (home-page
+     "https://github.com/NorfairKing/validity")
+    (synopsis
+     "Standard properties for functions on @code{Validity} types")
+    (description
+     "This package supplements the @code{Validity} typeclass with standard
+properties for functions operating on them.")
+    (license license:expat)))
+
 (define-public ghc-validity
   (package
     (name "ghc-validity")