summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-07-14 04:25:27 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-18 15:36:58 +0200
commita513a4cd1748e64f7ecbde6d9d98b4ffac423bf3 (patch)
tree94eb00eda6bde4ab75ea718343ad2ae4e2b49e64
parent8b65299c578e0fd02522b52aaba56137078125c7 (diff)
downloadguix-a513a4cd1748e64f7ecbde6d9d98b4ffac423bf3.tar.gz
gnu: Add emacs-focus.
* gnu/packages/emacs-xyz.scm (emacs-focus): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ef86197010..c48d3209d9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13745,6 +13745,30 @@ accept and reject GitHub pull requests.")
 searches with @code{ripgrep}.")
       (license license:gpl3+))))
 
+(define-public emacs-focus
+  (let ((commit "ab42b8779929beeb7878c7fb3d3ccd80d9327c7f")
+        (version "0.1.1")
+        (revision "1"))
+    (package
+      (name "emacs-focus")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/larstvei/Focus")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "079v1syid7h2vr2ya6hs6hl0pgj60qdsw60mqw4cj2zllmkrkwj4"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/larstvei/Focus")
+      (synopsis "Minor mode for focusing in on relevant text")
+      (description "This package provides a minor mode that dims the color of
+text in neighboring sections.")
+      (license license:gpl3+))))
+
 (define-public emacs-org-brain
   (package
     (name "emacs-org-brain")