summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-19 21:46:31 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-19 21:46:31 +0100
commitfb9821f0239fbc54a65d9635cff3798fba1a5651 (patch)
tree4cb286ab59398e880630f254ca63dc94c790fab0
parentcc8e5e25b4bc409b9dddfc0fe09b1958b6f7ae9e (diff)
downloadguix-fb9821f0239fbc54a65d9635cff3798fba1a5651.tar.gz
distro: Add GNU Zile.
* distro/packages/zile.scm: New file.
* Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am3
-rw-r--r--distro/packages/zile.scm65
2 files changed, 67 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 292b83fcc8..c61b924378 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,7 +69,8 @@ MODULES =					\
   distro/packages/readline.scm			\
   distro/packages/recutils.scm			\
   distro/packages/system.scm			\
-  distro/packages/texinfo.scm
+  distro/packages/texinfo.scm			\
+  distro/packages/zile.scm
 
 
 GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go
diff --git a/distro/packages/zile.scm b/distro/packages/zile.scm
new file mode 100644
index 0000000000..f5c6ba328b
--- /dev/null
+++ b/distro/packages/zile.scm
@@ -0,0 +1,65 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages zile)
+  #:use-module (guix download)
+  #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
+  #:use-module (distro packages bdw-gc)
+  #:use-module (distro packages perl)
+  #:use-module (distro packages help2man)
+  #:use-module (distro packages ncurses))
+
+(define-public zile
+  (package
+    (name "zile")
+    (version "2.4.9")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/zile/zile-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "0j801c28ypm924rw3lqyb6khxyslg6ycrv16wmmwcam0mk3mj6f7"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("boehm-gc" ,libgc)
+       ("ncurses" ,ncurses)
+       ("perl" ,perl)
+       ("help2man" ,help2man)))
+    (home-page "http://www.gnu.org/software/zile/")
+    (synopsis "GNU Zile, a lightweight Emacs clone")
+    (description
+     "GNU Zile, which is a lightweight Emacs clone.  Zile is short
+for Zile Is Lossy Emacs.  Zile has been written to be as
+similar as possible to Emacs; every Emacs user should feel at
+home.
+
+Zile has all of Emacs's basic editing features: it is 8-bit
+clean (though it currently lacks Unicode support), and the
+number of editing buffers and windows is only limited by
+available memory and screen space respectively.  Registers,
+minibuffer completion and auto fill are available.  Function
+and variable names are identical with Emacs's (except those
+containing the word \"emacs\", which instead contain the word
+\"zile\"!).
+
+However, all of this is packed into a program which typically
+compiles to about 130Kb.")
+    (license "GPLv3+")))