summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-24 00:57:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-24 02:30:41 +0200
commitfbde7b08e5ae0f45a3d6e89e2a3795a399a1e6dc (patch)
treebb75751a145eb35809f5a71ffd8979f692a5818c
parent0b4e5f7e5bd817a0c8cf19c68d92598eb164c934 (diff)
downloadguix-fbde7b08e5ae0f45a3d6e89e2a3795a399a1e6dc.tar.gz
gnu: ncmpc: Update to 0.29.
* gnu/packages/mpd.scm (ncmpc): Update to 0.29.
[build-system]: Switch to Meson.
[arguments]: Find ncurses.h.
[native-inputs]: Add gettext.
-rw-r--r--gnu/packages/mpd.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 29d59c5de4..2554ec9efd 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -185,7 +185,7 @@ player daemon.")
 (define-public ncmpc
   (package
     (name "ncmpc")
-    (version "0.27")
+    (version "0.29")
     (source (origin
               (method url-fetch)
               (uri
@@ -194,12 +194,16 @@ player daemon.")
                               "/ncmpc-" version ".tar.xz"))
               (sha256
                (base32
-                "1n8m7syhpgx24hfipixv66h2izn229jkxsmh2q5dzkv9r0znm8pr"))))
-    (build-system gnu-build-system)
+                "04jzv1hfdvgbn391523jb2h3yhq9a40pjrg41sl3wf3jf6vajs7g"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:configure-flags
+       (list "-Dcurses=ncurses")))
     (inputs `(("glib" ,glib)
               ("libmpdclient" ,libmpdclient)
               ("ncurses" ,ncurses)))
-    (native-inputs `(("pkg-config" ,pkg-config)))
+    (native-inputs `(("gettext" ,gettext-minimal) ; for xgettext
+                     ("pkg-config" ,pkg-config)))
     (synopsis "Curses Music Player Daemon client")
     (description "ncmpc is a fully featured MPD client, which runs in a
 terminal using ncurses.")