summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-03-01 15:42:11 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-01 16:31:53 +0100
commitf2f530e808c26360f2697bd975f1afd599a5de29 (patch)
treec6dfcfa3ee6607c041b848071ac9b5db03bc1f72
parentf3a3e5fc763b5a6216ca11dfe012ee05c6e485d0 (diff)
downloadguix-f2f530e808c26360f2697bd975f1afd599a5de29.tar.gz
gnu: xmrig: Update to 6.19.0.
* gnu/packages/finance.scm (xmrig): Update to 6.19.0.
-rw-r--r--gnu/packages/finance.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 932964e1c5..8e1c8fd568 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -2194,7 +2194,7 @@ and manipulation.")
 (define-public xmrig
   (package
     (name "xmrig")
-    (version "6.18.1")
+    (version "6.19.0")
     (source
      (origin
        (method git-fetch)
@@ -2202,17 +2202,19 @@ and manipulation.")
              (url "https://github.com/xmrig/xmrig")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
-       (sha256 (base32 "0f0kly374pkgnpnx60hac0bg9297a5zhycss6p37iavayn28jg39"))
+       (sha256 (base32 "10vaq6ld4sddnpmv9dg71fjvw1jrfaddrp3bq6p3dxhsl153khm4"))
        (modules '((guix build utils)))
        (snippet
         ;; TODO: Try to use system libraries instead of bundled ones in
         ;; "src/3rdparty/". It requires changes to some "cmake/..." scripts
         ;; and to some source files.
-        #~(substitute* "src/donate.h"
-            (("constexpr const int kDefaultDonateLevel = 1;")
-             "constexpr const int kDefaultDonateLevel = 0;")
-            (("constexpr const int kMinimumDonateLevel = 1;")
-             "constexpr const int kMinimumDonateLevel = 0;")))))
+        #~(begin
+            (delete-file-recursively "src/3rdparty/hwloc")
+            (substitute* "src/donate.h"
+              (("constexpr const int kDefaultDonateLevel = 1;")
+               "constexpr const int kDefaultDonateLevel = 0;")
+              (("constexpr const int kMinimumDonateLevel = 1;")
+               "constexpr const int kMinimumDonateLevel = 0;"))))))
     (build-system cmake-build-system)
     (inputs
      (list