summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:13:31 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:30 -0400
commit059365b96904c788d06a995d61d9e00d40a44963 (patch)
tree7c69b6489aa0f95a4b8c7c514435e164efe04f1b
parentc7353caca5ff7dc5e7e76ec5d164535d7b08425e (diff)
downloadguix-059365b96904c788d06a995d61d9e00d40a44963.tar.gz
gnu: Remove python2-parse-type.
* gnu/packages/python-xyz.scm (python2-parse-type): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5f8ba8855b..66cfbb77f6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2922,20 +2922,9 @@ backported for previous versions of Python from 2.4 to 3.3.")
     (native-inputs (list python-pytest))
     (home-page "https://github.com/jenisys/parse_type")
     (synopsis "Extended parse module")
-    (description
-     "Parse_type extends the python parse module.")
-    (properties
-     `((python2-variant . ,(delay python2-parse-type))))
+    (description "Parse_type extends the python parse module.")
     (license license:bsd-3)))
 
-(define-public python2-parse-type
-  (let ((base (package-with-python2
-                (strip-python2-variant python-parse-type))))
-    (package/inherit base
-      (propagated-inputs
-       `(("python2-enum34" ,python2-enum34)
-         ,@(package-propagated-inputs base))))))
-
 (define-public python-parse
   (package
     (name "python-parse")