summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-05-25 15:49:05 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-06-04 13:34:49 +0200
commit156b8f9cd2bbbb9580dd01a30a9891fddf79362c (patch)
tree88c7266ce590ec4c097a7fecec4fe350e87fec4e
parent09be86744f296b54680755fd873c22602b739ad8 (diff)
downloadguix-156b8f9cd2bbbb9580dd01a30a9891fddf79362c.tar.gz
gnu: qemacs: Use 'native-inputs' instead of '%build-inputs'.
In build phases, the former (or 'inputs', as appropriate) is preferred.

* gnu/packages/text-editors.scm
  (qemacs)[arguments]<#:phases>{install-extra-documentation}: Use
  'native-inputs' argument instead of '%build-inputs'.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/text-editors.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index eb557cb80a..193b6ba702 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -524,13 +524,14 @@ OpenBSD team.")
                #t)))
          (add-after 'install 'install-extra-documentation
            ;; Install sample configuration file, Info, and HTML manual.
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
              (let* ((share (string-append (assoc-ref outputs "out") "/share"))
                     (doc (string-append share "/doc/" ,name "-" ,version))
                     (html (string-append share "/html"))
                     (info (string-append share "/info"))
-                    (makeinfo (string-append (assoc-ref %build-inputs "texinfo")
-                                             "/bin/makeinfo")))
+                    (makeinfo (string-append
+                               (assoc-ref (or native-inputs inputs) "texinfo")
+                               "/bin/makeinfo")))
                ;; First fix Texinfo documentation, create appropriate
                ;; directories, then generate Info and HTML files there.
                (substitute* "qe-doc.texi"