summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:14 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:27 +0200
commit2c4e00225b05f2e0b0b5102c3dc78a45374ca669 (patch)
tree744c5580b3ff3955d5ef7938bfc98ddd79f74dd1
parentd65f851365f77bdaef5377614375727c73c7ae2d (diff)
downloadguix-2c4e00225b05f2e0b0b5102c3dc78a45374ca669.tar.gz
gnu: Add trytond-analytic-sale.
* gnu/packages/tryton.scm (trytond-analytic-sale): New variable.
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 9ef5178598..3df4094492 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1360,6 +1360,30 @@ analytic accounts on invoice line.")
 analytic accounts on purchase line.")
     (license license:gpl3+)))
 
+(define-public trytond-analytic-sale
+  (package
+    (name "trytond-analytic-sale")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_analytic_sale" version))
+       (sha256
+        (base32 "07l97jmg67468pihymfcjagqbbfdcmry3654f24zbmnljxy2qm1x"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "analytic_sale"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-analytic-account" ,trytond-analytic-account)
+       ("trytond-analytic-invoice" ,trytond-analytic-invoice)
+       ("trytond-sale" ,trytond-sale)))
+    (home-page "https://docs.tryton.org/projects/modules-analytic-sale")
+    (synopsis "Tryton module to add analytic accounting on sale")
+    (description "The @emph{Analytic Sale} Tryton module allows to set
+analytic accounts on sale line.")
+    (license license:gpl3+)))
+
 (define-public trytond-company
   (package
     (name "trytond-company")