summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-06-20 03:38:35 -0400
committerMark H Weaver <mhw@netris.org>2017-06-20 03:38:35 -0400
commit2e701cd3841d4449b3963d4337c543be99ed7bcc (patch)
tree613f8698657c8748b5910a8c66d03137a8d08372
parent53321ad3881fec8618ce85f65987dd95d0fa3d76 (diff)
downloadguix-2e701cd3841d4449b3963d4337c543be99ed7bcc.tar.gz
gnu: linux-libre-arm-generic: Add mitigation for CVE-2017-1000364.
This is a followup to commit 91c623aae0f10992aa46957b9072679534e4cd28.

* gnu/packages/linux.scm (linux-libre-arm-generic): Add patch to mitigate
CVE-2017-1000364.
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3ec423422b..03cf8ed2a4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -420,7 +420,17 @@ https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable-rc.git/patch
                     %linux-libre-hash
                     '("armhf-linux")
                     #:defconfig "multi_v7_defconfig"
-                    #:extra-version "arm-generic"))
+                    #:extra-version "arm-generic"
+                    #:patches
+                    (list %boot-logo-patch
+                          (origin
+                            (method url-fetch)
+                            (uri "\
+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable-rc.git/patch/?id=167ec8235f978d7af78c73e9490dae1af3fee67f")
+                            (file-name "linux-libre-4.11-CVE-2017-1000364.patch")
+                            (sha256
+                             (base32
+                              "0hv3lxjgpssvsldkydg5q7znnzxv5ncpzrk6g11q01k3gkl0q689"))))))
 
 
 ;;;