summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-10-20 23:45:38 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-23 19:41:10 +0200
commit31288222d4aaf49e891e24b651c9cad5198026e4 (patch)
tree949324256777b6722e8045e4564f8899d0b1b7fe
parent999d964d64a57eed7ce5790f1194118bdac5aae4 (diff)
downloadguix-31288222d4aaf49e891e24b651c9cad5198026e4.tar.gz
gnu: Add python-flask-basicauth.
* gnu/packages/python.scm (python-flask-basicauth): New variable.
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 80335c46b6..57d09f9978 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11285,3 +11285,25 @@ useful as a validator for JSON data.")
     (description
       "This package contains a Flask module for creating REST APIs.")
     (license license:bsd-3)))
+
+(define-public python-flask-basicauth
+  (package
+    (name "python-flask-basicauth")
+    (version "0.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Flask-BasicAuth" version))
+        (sha256
+          (base32
+            "1zq1spkjr4sjdnalpp8wl242kdqyk6fhbnhr8hi4r4f0km4bspnz"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-flask" ,python-flask)))
+    (home-page
+      "https://github.com/jpvanhal/flask-basicauth")
+    (synopsis
+      "HTTP basic access authentication for Flask")
+    (description
+      "This package provides HTTP basic access authentication for Flask.")
+    (license license:bsd-3)))