summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:30:32 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:11 +0200
commit3a3a68eb4d5da031ff0a20ae32512c1c93d685be (patch)
treecf0afffe0756f392468ef5384c658233fcaf044e
parentd4e3d212bc4a614036d03da311ae8e8d5b4234a5 (diff)
downloadguix-3a3a68eb4d5da031ff0a20ae32512c1c93d685be.tar.gz
gnu: emacs-gitpatch: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-gitpatch)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a2428beca8..5de7b85d58 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7748,13 +7748,13 @@ internally.")
     (version "0.5.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/tumashu/gitpatch/archive/"
-                           "v" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tumashu/gitpatch.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1yj6pmic541lcnscjin300k380qp9xdfprs55xg1q57jrkq6f6k7"))))
+        (base32 "1jj12pjwza6cq8a3kr8nqnmm3vxs0wam8h983irry4xr4ifywsn4"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/tumashu/gitpatch")
     (synopsis "Mail git patch from Emacs")