summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:33 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commit42209cf3fe52ae52cfc38bff54874f86edaa2e69 (patch)
tree37652b03bf350fe509c8418f5c299ba278c4d223
parentc7d42009c112572f481aa8ce83bd39f40fdeee9c (diff)
downloadguix-42209cf3fe52ae52cfc38bff54874f86edaa2e69.tar.gz
gnu: Add trytond-purchase-history.
* gnu/packages/tryton.scm (trytond-purchase-history): New variable.
-rw-r--r--gnu/packages/tryton.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index b62d7c00c5..4fef20061a 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2738,6 +2738,29 @@ amendment is composed of action lines which can:
 @end itemize")
     (license license:gpl3+)))
 
+(define-public trytond-purchase-history
+  (package
+    (name "trytond-purchase-history")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_purchase_history" version))
+       (sha256
+        (base32 "18mb1vqmf9c934jp2qjwj4mi0sx99m8005vxc42mjj1f5qkxxsgg"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "purchase_history"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-purchase" ,trytond-purchase)))
+    (home-page "https://docs.tryton.org/projects/modules-purchase-history")
+    (synopsis "Tryton module to historize purchases")
+    (description "The @emph{Purchase History} Tryton module activates the
+historization of the purchase and adds a revision counter which increases each
+time the purchase is reset to draft.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase-request
   (package
     (name "trytond-purchase-request")