summary refs log tree commit diff
diff options
context:
space:
mode:
authorMilkey Mouse <milkeymouse@meme.institute>2021-09-03 16:26:52 -0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-09-07 14:41:11 +0200
commit44db980932fa7cf5fe23300303efcd2263c22cfc (patch)
tree6d53f025ab5535b3904fac211e779285b8dbec1c
parent7f6869c43438281ac76cd759cada0db4e997e2d3 (diff)
downloadguix-44db980932fa7cf5fe23300303efcd2263c22cfc.tar.gz
gnu: Add slurm-monitor.
* gnu/packages/networking.scm (slurm-monitor): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/networking.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 0b130a9627..7f0b7f53cc 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -44,6 +44,7 @@
 ;;; Copyright © 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -384,6 +385,30 @@ supported, including rtmp://, rtmpt://, rtmpe://, rtmpte://, and rtmps://.")
         ;; Others.
         license:gpl2+)))))
 
+(define-public slurm-monitor
+  (package
+    (name "slurm-monitor")
+    (version "0.4.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/mattthias/slurm")
+         (commit (string-append "upstream/" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1n6pgrcs8gwrcq5fch1q3yk3jipjwrf21s9a13fbjrl903g5zzv9"))))
+    (build-system cmake-build-system)
+    (arguments `(#:tests? #f)) ;no tests
+    (inputs `(("ncurses" ,ncurses)))
+    (synopsis "Network load monitor")
+    (description
+     "Slurm is a network load monitor.  It shows real-time traffic statistics
+from any network device in any of three ASCII graph formats.")
+    (home-page "https://github.com/mattthias/slurm")
+    (license license:gpl2)))
+
 (define-public srt
   (package
     (name "srt")