summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 12:32:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:20 +0200
commit4b2ceb27532bba4289429d17e514fbc2dc994553 (patch)
tree8d66003136b4b9162707669c376c3fbfa18bf849
parentd085624bdab0c3b500e84696cfcaf097eed82930 (diff)
downloadguix-4b2ceb27532bba4289429d17e514fbc2dc994553.tar.gz
gnu: Add texlive-ntheorem.
* gnu/packages/tex.scm (texlive-ntheorem): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index efeb64931e..3c9186c19d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11954,6 +11954,30 @@ TeX users have no access to package options, so need to redefine macros for
 these changes.")
     (license license:public-domain)))
 
+(define-public texlive-ntheorem
+  (package
+    (name "texlive-ntheorem")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ntheorem/" "source/latex/ntheorem/"
+                   "tex/latex/ntheorem/")
+             (base32
+              "16xain8s0azcnhwj5xwh3m365sb9bhdvxanh19kvmnc52dggjc1y")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-amsfonts))
+    (home-page "https://ctan.org/pkg/ntheorem")
+    (synopsis "Enhanced theorem environment")
+    (description
+     "The package offers enhancements for theorem-like environments: easier
+control of layout; proper placement of endmarks even when the environment ends
+with @code{\\end@{enumerate@}} or @code{\\end@{displaymath@}} (including
+support for @code{amsmath} displayed-equation environments); and support for
+making a list of theorems, analagous to @code{\\listoffigures}.")
+    (license license:lppl)))
+
 (define-public texlive-fmtcount
   (package
     (inherit (simple-texlive-package