summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:25:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:49 +0200
commit5ba584fddda7fa8fd17e7f7fb07c0f4b3a9923a0 (patch)
tree2a6c5406826b9adc10d9a2e5465df3888a438c41
parentc3a49731f637d46c891c5b0b17056197438097dd (diff)
downloadguix-5ba584fddda7fa8fd17e7f7fb07c0f4b3a9923a0.tar.gz
gnu: Add texlive-texdoc.
* gnu/packages/tex.scm (texlive-texdoc): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a824a0b702..25a9577bc4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6355,6 +6355,30 @@ component files, are then all put into a single directory (thus flattening the
 document's directory tree).")
     (license license:artistic2.0)))
 
+(define-public texlive-texdoc
+  (package
+    (name "texlive-texdoc")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/texdoc.1"
+                   "doc/man/man1/texdoc.man1.pdf"
+                   "doc/support/texdoc/" "scripts/texdoc/"
+                   "texdoc/")
+             (base32
+              "19mvh7pm2332f6c8nzgcbscm9vcz0apwfgm0m55ycibssc2fb3ww")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "texdoc.tlu")))
+    (propagated-inputs (list texlive-kpathsea))
+    (home-page "https://ctan.org/pkg/texdoc")
+    (synopsis "Documentation access for TeX Live")
+    (description
+     "@command{texdoc} is a Lua script providing easy access to the
+documentation in TeX Live: PDF, DVI, plain text files, and more.  Viewing and
+other configuration can be extensively customized.")
+    (license license:gpl3+)))
+
 (define-public texlive-texdraw
   (package
     (name "texlive-texdraw")