summary refs log tree commit diff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-12-03 09:12:15 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-02-12 08:45:35 +0100
commit629a5936a6dfa0fe2cc2a3092ec51920b216b652 (patch)
tree6298915c8dac62c3cbfe3e1a7eec337013054d8e
parente6ff91bfc4fabc92bde87e4db6fd3057a44fca37 (diff)
downloadguix-629a5936a6dfa0fe2cc2a3092ec51920b216b652.tar.gz
gnu: openscenegraph: Use modern package style.
* gnu/packages/graphics.scm (openscenegraph)[arguments]: Convert to list
of G-Expressions.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/graphics.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index d9359d0b85..90e9259540 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1354,14 +1354,15 @@ visual effects work for film.")
      `((upstream-name . "OpenSceneGraph")))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f                      ; no test target available
-       ;; Without this flag, 'rd' will be added to the name of the
-       ;; library binaries and break linking with other programs.
-       #:build-type "Release"
-       #:configure-flags
-       (list (string-append "-DCMAKE_INSTALL_RPATH="
-                            (assoc-ref %outputs "out") "/lib:"
-                            (assoc-ref %outputs "out") "/lib64"))))
+     (list
+      #:tests? #f                      ; no test target available
+      ;; Without this flag, 'rd' will be added to the name of the
+      ;; library binaries and break linking with other programs.
+      #:build-type "Release"
+      #:configure-flags
+      #~(list (string-append "-DCMAKE_INSTALL_RPATH="
+                             #$output "/lib:"
+                             #$output "/lib64"))))
     (native-inputs
      (list pkg-config unzip))
     (inputs