summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:53 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:34 +0200
commit6497924b977751a5adcadff8faa9e6ff5c7c5089 (patch)
treedc7db249b5d2162424627a0661f2e8f25ea19a22
parentf5c8be25333d8673bc4db4c5a5a83ec9968510fe (diff)
downloadguix-6497924b977751a5adcadff8faa9e6ff5c7c5089.tar.gz
gnu: Add trytond-stock-quantity-early-planning.
* gnu/packages/tryton.scm (trytond-stock-quantity-early-planning): New variable.
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 586dfa325e..956e606c6f 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4051,6 +4051,32 @@ use as default destination the preferred locations associated to the current
 warehouse.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-quantity-early-planning
+  (package
+    (name "trytond-stock-quantity-early-planning")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_quantity_early_planning" version))
+       (sha256
+        (base32 "05djbhz82wjkgvfvlzkhzi94nfg0cif3jfmh1jv0zixzfv87chqs"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_quantity_early_planning"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-production" ,trytond-production)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-stock-quantity-early-planning")
+    (synopsis "Tryton module to plan earlier shipments and productions")
+    (description "The @emph{Stock Quantity Early Planning} Tryton module helps
+reducing stock level by proposing to consume earlier.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-supply
   (package
     (name "trytond-stock-supply")