summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 14:04:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:32 +0200
commit65eb3ff97d708a40d65f6d07ce020c5912daf591 (patch)
treef744f224b2ec5388efce9e341971aca11414fc54
parent7a6e4797497abedf34217717584a1c61580126f0 (diff)
downloadguix-65eb3ff97d708a40d65f6d07ce020c5912daf591.tar.gz
gnu: texlive-qrcode: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-qrcode!): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[native-inputs]: Remove them.
[description]: Shorten it.
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 13 insertions, 21 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dd05a2d8f8..5840646701 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12162,33 +12162,25 @@ provided box macros are @code{\\lapbox}, @code{\\marginbox},
 
 (define-public texlive-qrcode
   (package
-    (inherit (simple-texlive-package
-              "texlive-qrcode"
-              (list "doc/latex/qrcode/README"
-                    "source/latex/qrcode/qrcode.dtx"
-                    "source/latex/qrcode/qrcode.ins")
-              (base32
-               "1xfv0imrrbxjqwjapcf2silg19rwz2jinawy1x65c1krg919vn02")))
+    (name "texlive-qrcode")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/qrcode/" "source/latex/qrcode/"
+                   "tex/latex/qrcode/")
+             (base32
+              "197v18lsvb90i07gxvc6mrmn1z63q8v0wvcnbk8dnn3hhabpn16y")))
     (outputs '("out" "doc"))
-    (arguments
-     (list
-      #:tex-directory "latex/qrcode"))
+    (build-system texlive-build-system)
     (propagated-inputs
      (list texlive-lm
            texlive-xcolor
            texlive-xkeyval))
-    (native-inputs
-     (list (texlive-updmap.cfg (list texlive-lm texlive-zapfding))
-           texlive-hyperref
-           texlive-stringenc
-           texlive-xcolor
-           texlive-xkeyval))
-    (home-page "https://www.ctan.org/pkg/qrcode")
+    (home-page "https://ctan.org/pkg/qrcode")
     (synopsis "QR codes without external tools")
-    (description "This package creates @acronym{QR,Quick Response} codes for
-LaTeX documents without depending on external graphics packages.  It supports
-generating codes of different sizes and with different error correction
-levels.  All functionality is provided by the single @code{\\qrcode} command.")
+    (description
+     "The package generates QR (Quick Response) codes in LaTeX, without the
+need for PSTricks or any other graphical package.")
     (license license:lppl1.3c+)))
 
 (define-public texlive-tcolorbox