summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-10-03 15:07:00 -0400
committerEfraim Flashner <efraim@flashner.co.il>2021-10-04 11:23:58 +0300
commit69d7efbf996e42dbc2df2e570630af62de0ca6df (patch)
tree125c8c2db6c9972fdf04a89410598a2cb4aba3f9
parent6ac237d87b238be04fe841ef1a70c7c710b30f67 (diff)
downloadguix-69d7efbf996e42dbc2df2e570630af62de0ca6df.tar.gz
gnu: python-uqbar: Update to 0.5.6.
* gnu/packages/graphviz.scm (python-uqbar): Update to 0.5.6.
[arguments]: Update setup.py version requirements.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/graphviz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 5685864d4c..ac896fb577 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -258,7 +258,7 @@ structure and layout algorithms.")
 (define-public python-uqbar
   (package
     (name "python-uqbar")
-    (version "0.5.1")
+    (version "0.5.6")
     (source
      (origin
        (method git-fetch)
@@ -268,7 +268,7 @@ structure and layout algorithms.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0413nyhd8z8v3lvsgaghhafnyxg90fi1q80j1kbl21gpmpnc9a7n"))))
+         "1ml3x2mf7nlnvrh9lari5yk0sz2mmg39jwsbjxnpzhnw4kcwpdrs"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -277,8 +277,8 @@ structure and layout algorithms.")
            (lambda _
              (substitute* "setup.py"
                ;; Latest versions of sphink-rtd-theme require npm to build.
-               (("sphinx-rtd-theme >= 0.4.0") "sphinx-rtd-theme >= 0.2.4")
-               (("black == 19.10b0") "black >= 19.10b0"))
+               (("sphinx-rtd-theme >= 0.5.0") "sphinx-rtd-theme >= 0.2.4")
+               (("black") "black >= 19.10b0"))
              #t))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)