summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-11-18 16:47:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 12:12:21 +0100
commit6e396c4bff6c79befdc3e255b7d21c6af1774c5e (patch)
tree7a52cf97f733e2a3d310ce16b57b12721e50628d
parentc84762c446bb2c98aecc1d94009fcc3137d5fd04 (diff)
downloadguix-6e396c4bff6c79befdc3e255b7d21c6af1774c5e.tar.gz
gnu: Add r-greylistchip.
* gnu/packages/bioconductor.scm (r-greylistchip): New variable.
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 56d8036899..d8db2ba83b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1657,6 +1657,33 @@ effect sizes for a variety of GLM models, using approximation of the
 posterior for individual coefficients.")
    (license license:gpl2)))
 
+(define-public r-greylistchip
+  (package
+   (name "r-greylistchip")
+   (version "1.22.0")
+   (source (origin
+            (method url-fetch)
+            (uri (bioconductor-uri "GreyListChIP" version))
+            (sha256
+             (base32
+              "1d1yvza1aw3vs3di6mrra5l52ig0p9bpzprrqvknjaz5i4yb8ma6"))))
+   (properties `((upstream-name . "GreyListChIP")))
+   (build-system r-build-system)
+   (propagated-inputs
+    `(("r-bsgenome" ,r-bsgenome)
+      ("r-genomeinfodb" ,r-genomeinfodb)
+      ("r-genomicalignments" ,r-genomicalignments)
+      ("r-genomicranges" ,r-genomicranges)
+      ("r-mass" ,r-mass)
+      ("r-rsamtools" ,r-rsamtools)
+      ("r-rtracklayer" ,r-rtracklayer)
+      ("r-summarizedexperiment" ,r-summarizedexperiment)))
+   (home-page "https://bioconductor.org/packages/GreyListChIP")
+   (synopsis "Greylist artefact regions based on ChIP inputs")
+   (description "This package identifies regions of ChIP experiments with high
+signal in the input, that lead to spurious peaks during peak calling.")
+   (license license:artistic2.0)))
+
 (define-public r-diffbind
   (package
     (name "r-diffbind")