summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-17 09:05:03 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-17 09:05:03 +0100
commit728ed83188846453f1319ea425847da8200a55a9 (patch)
treefb2db4923381b928cd867037c1f2b54790f83e41
parentc0d3d494cd6420f2e58d42d566f2af54846bcf13 (diff)
downloadguix-728ed83188846453f1319ea425847da8200a55a9.tar.gz
gnu: Remove harfbuzz-5.
As this package definition is redundant, harfbuzz is version 5.3.1.

* gnu/packages/gtk.scm (harfbuzz-5): Remove.
* gnu/packages/libreoffice.scm (libreoffice)[inputs]: Replace harfbuzz-5 with
harfbuzz.
* gnu/packages/qt.scm (qtwebengine)[inputs]: Remove redundant replace.
-rw-r--r--gnu/packages/gtk.scm14
-rw-r--r--gnu/packages/libreoffice.scm2
-rw-r--r--gnu/packages/qt.scm1
3 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index ca41612e90..9621357b99 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -286,20 +286,6 @@ output.  Experimental backends include OpenGL, BeOS, OS/2, and DirectFB.")
                                 "See 'COPYING' in the distribution."))
     (home-page "https://www.freedesktop.org/wiki/Software/HarfBuzz/")))
 
-
-(define-public harfbuzz-5
-  (package
-    (inherit harfbuzz)
-    (version "5.3.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/harfbuzz/harfbuzz"
-                                  "/releases/download/" version "/harfbuzz-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "0ka3nkk2lks2lgakq02vyibwdziv11dkpa2brkx230asnyby0v2a"))))))
-
 (define-public libdatrie
   (package
     (name "libdatrie")
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 04279fff63..d06166e64a 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1117,7 +1117,7 @@ commonly called @code{ftoa} or @code{dtoa}.")
            graphite2
            gst-plugins-base
            gtk+
-           harfbuzz-5
+           harfbuzz
            hunspell
            hyphen
            libabw
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index de070ecaf3..c3d7d02fe7 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3126,7 +3126,6 @@ linux/libcurl_wrapper.h"
     (inputs
      (modify-inputs (package-inputs qtwebengine-5)
        (replace "qtmultimedia" qtmultimedia)
-       (replace "harfbuzz" harfbuzz-5)
        (append libxkbfile xkeyboard-config)))
     (propagated-inputs
      (modify-inputs (package-propagated-inputs qtwebengine-5)