summary refs log tree commit diff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-05-22 11:04:17 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-19 07:33:55 +0200
commit72dbad505abcf360e2fedb747aad2ad7f4a0c326 (patch)
tree84758beaa08f26508fca8bc47546714fd9e4292b
parentc1840e9442f7e69fa864553346e3af1c4c4f5ada (diff)
downloadguix-72dbad505abcf360e2fedb747aad2ad7f4a0c326.tar.gz
gnu: mig: Use git-fetch.
Now that we have `git-fetch-from-tarball' to break the cycle in commencement
for git-fetch sources, we can finally update mig to use git-fetch to allow
`--with-commit' builds.

* gnu/packages/hurd.scm (mig)[source]: Use git-fetch again.
* gnu/packages/commencement.scm (mig-boot0)[source]: Use
git-fetch-from-tarball accordingly.
-rw-r--r--gnu/packages/commencement.scm14
-rw-r--r--gnu/packages/hurd.scm17
2 files changed, 20 insertions, 11 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index f2d3b96c1a..687153f0fc 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2700,7 +2700,19 @@ memoized as a function of '%current-system'."
      (inherit mig)
      (name "mig-boot0")
      (version "1.8+git20230520")
-     (source (origin (inherit (package-source mig))))
+     (source
+      (origin
+        (inherit (package-source mig))
+        (method
+         (git-fetch-from-tarball
+          (origin
+            (method url-fetch)
+            (uri (string-append
+                  "https://git.savannah.gnu.org/cgit/hurd/mig.git/snapshot/"
+                  "mig-" version ".tar.gz"))
+            (sha256
+             (base32
+              "1l1vfm4wap5yxylv91wssgpy7fnq22wp3akgd5nv995kychfa9jy")))))))
      (native-inputs (list autoconf-boot0 automake-boot0 bison-boot0 flex-boot0
                           gnumach-headers-boot0))
      (inputs (list flex-boot0 gnumach-headers-boot0))
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index b184657fb9..4064a9e2e8 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -93,21 +93,18 @@
     (name "mig")
     (version "1.8+git20230520")
     (source (origin
-              (method url-fetch)
-              ;; XXX: Versions 2.35 and 2.37 of glibc can only be built with an
-              ;; unreleased version of MiG:
-              ;; <https://lists.gnu.org/archive/html/bug-hurd/2023-03/msg00025.html>.
-              ;; It cannot be fetched from Git though, as the extra dependency
-              ;; on Autoconf/Automake would complicate bootstrapping.
-              (uri (string-append "mirror://gnu/guix/mirror/mig-"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.savannah.gnu.org/git/hurd/mig.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ap31jd9jkvvz3vb88hg19cyqmqzmra724yl1xhcrv7gcgnan7d9"))))
+                "10r0fdjqjzqsy6ajb21rifvhw0wpjvrw6a1zdyliqlzqny5k0qlz"))))
     (build-system gnu-build-system)
     ;; Flex is needed both at build and run time.
     (inputs (list gnumach-headers flex))
-    (native-inputs (list flex bison))
+    (native-inputs (list autoconf automake flex bison))
     (arguments
      (list #:tests? #f
            #:phases