summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-25 13:53:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-25 13:57:32 +0200
commit743e5adf4727c41f110b5bbae3a3558c65fd86be (patch)
tree5a7ea5a6c3c62739a2b940eae1d083a3f5e2f154
parent822166ac31e4c3d47fdd061671c5deb2f8d5b392 (diff)
downloadguix-743e5adf4727c41f110b5bbae3a3558c65fd86be.tar.gz
gnu: Add python-rtf-tokenize.
* gnu/packages/python-xyz.scm (python-rtf-tokenize): New variable.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 51136d8e6e..08a33061a9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12035,6 +12035,23 @@ independent alignment of columns (left or right justified or centred) and
 printing of sub-tables by specifying a row range.")
     (license license:bsd-3)))
 
+(define-public python-rtf-tokenize
+  (package
+    (name "python-rtf-tokenize")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "rtf_tokenize" version))
+              (sha256
+               (base32
+                "026njb9iwznycda83bln3gfivcnzdz6vy8y86xvbsy84s28g6gaw"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/benoit-pierre/rtf_tokenize")
+    (synopsis "Simple RTF tokenizer")
+    (description "This package is a simple RTF tokenizer.")
+    (license license:gpl2+)))
+
 (define-public python-curio
   (package
     (name "python-curio")