summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-12 17:02:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-12 17:05:10 +0300
commit76fc36d0a7215979bb74c05840f5a4de4ab5ea93 (patch)
tree1cb84a53c060fc33095fcc7eee9ef02c2f6f0f46
parenta55f64917dc9a56d5a95de625bc3092b625df0ed (diff)
downloadguix-76fc36d0a7215979bb74c05840f5a4de4ab5ea93.tar.gz
gnu: gcc: Update gcc to 8.
* gnu/packages/gcc.scm (gcc): Define as gcc-8.
* gnu/packages/commencement.scm (gcc-toolchain-7): Use
make-gcc-toolchain procedure.
(gcc-toolchain-8): Define as gcc-toolchain.
* gnu/packages/game-development (python2-renpy)[native-inputs],
* gnu/packages/gnome.scm (gnome-commander)[native-inputs],
* gnu/packages/wm.scm (waybar)[native-inputs]: Remove gcc-8.
-rw-r--r--gnu/packages/commencement.scm4
-rw-r--r--gnu/packages/game-development.scm3
-rw-r--r--gnu/packages/gcc.scm2
-rw-r--r--gnu/packages/gnome.scm1
-rw-r--r--gnu/packages/wm.scm3
5 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 3eba960447..36ebcee163 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3816,10 +3816,10 @@ is the GNU Compiler Collection.")
   (make-gcc-toolchain gcc-6))
 
 (define-public gcc-toolchain-7
-  gcc-toolchain)
+  (make-gcc-toolchain gcc-7))
 
 (define-public gcc-toolchain-8
-  (make-gcc-toolchain gcc-8))
+  gcc-toolchain)
 
 (define-public gcc-toolchain-9
   (make-gcc-toolchain gcc-9))
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 1ae69d5c4d..21a4ef8c0d 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1226,8 +1226,7 @@ developed mainly for Ren'py.")
      `(("python2-future" ,python2-future)
        ("python2-pygame" ,python2-pygame-sdl2)))
     (native-inputs
-     `(("gcc" ,gcc-8) ; for const variables as initializer elements
-       ("python2-cython" ,python2-cython)
+     `(("python2-cython" ,python2-cython)
        ("xdg-utils" ,xdg-utils)))
     (home-page "https://www.renpy.org/")
     (synopsis "Ren'py python module")
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 13d6b20801..e9f5889570 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -585,7 +585,7 @@ It also includes runtime support libraries for these languages.")))
 ;; Note: When changing the default gcc version, update
 ;;       the gcc-toolchain-* definitions and the gfortran definition
 ;;       accordingly.
-(define-public gcc gcc-7)
+(define-public gcc gcc-8)
 
 (define-public (make-libstdc++ gcc)
   "Return a libstdc++ package based on GCC.  The primary use case is when
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f296fa37d4..f5a8a4d2bd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1803,7 +1803,6 @@ either on a local, or remote machine via a number of methods.")
     (build-system glib-or-gtk-build-system)
     (native-inputs
      `(("desktop-file-utils" ,desktop-file-utils)
-       ("gcc" ,gcc-8) ;required for -Wcast-function-type
        ("gettext" ,gettext-minimal)
        ("glib:bin" ,glib "bin")
        ("gobject-introspection" ,gobject-introspection)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index e80c776f6d..3aec9455e0 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1594,8 +1594,7 @@ modules for building a Wayland compositor.")
               ("spdlog" ,spdlog-1.7)
               ("wayland" ,wayland)))
     (native-inputs
-     `(("gcc" ,gcc-8)                   ; for #include <filesystem>
-       ("glib:bin" ,glib "bin")
+     `(("glib:bin" ,glib "bin")
        ("pkg-config" ,pkg-config)
        ("scdoc" ,scdoc)
        ("wayland-protocols" ,wayland-protocols)))