summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 14:01:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:32 +0200
commit7a6e4797497abedf34217717584a1c61580126f0 (patch)
treee858354967109e8ed8adbb233ab44125a2fd8569
parentc2764fc7e255c17671d8b540c20a3f73f50bf312 (diff)
downloadguix-7a6e4797497abedf34217717584a1c61580126f0.tar.gz
gnu: texlive-grfext: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-grfext!): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-INFWARERR, TEXLIVE-KVDEFINEKEYS.
[home-page]: Use CTAN URL.
[synopsis]: Add proper Texinfo markup.
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 541be156ae..dd05a2d8f8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12102,27 +12102,26 @@ The macros were designed for use within other macros.")
     (license license:lppl1.3)))
 
 (define-public texlive-grfext
-  (let ((template (simple-texlive-package
-                   "texlive-grfext"
-                   (list "doc/latex/grfext/"
-                         "source/latex/grfext/"
-                         "tex/latex/grfext/")
-                   (base32
-                    "1x35r10mkjg8dzx7aj99y4dwyf69jgs41qwapdx523lbglywmgxp"))))
-    (package
-      (inherit template)
-      (outputs '("out" "doc"))
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ #t)
-          "latex/grfext")
-         ((#:build-targets _ #t)
-          #~(list "grfext.dtx"))))
-      (home-page "https://github.com/ho-tex/grfext")
-      (synopsis "Manipulate the graphics package's list of extensions")
-      (description "This package provides macros for adding to, and reordering
-the list of graphics file extensions recognised by package graphics.")
-      (license license:lppl1.3c+))))
+  (package
+    (name "texlive-grfext")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/grfext/" "source/latex/grfext/"
+                   "tex/latex/grfext/")
+             (base32
+              "1x35r10mkjg8dzx7aj99y4dwyf69jgs41qwapdx523lbglywmgxp")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-infwarerr
+           texlive-kvdefinekeys))
+    (home-page "https://ctan.org/pkg/grfext")
+    (synopsis "Manipulate the @code{graphics} package's list of extensions")
+    (description
+     "This package provides macros for adding to, and reordering the list of
+graphics file extensions recognised by package @code{graphics}.")
+    (license license:lppl1.3c+)))
 
 (define-public texlive-adjustbox
   (package