summary refs log tree commit diff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-07-02 18:18:08 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-31 01:03:24 +0200
commit82cfefc2a04aa43e8444a671ba2cdde171cda032 (patch)
treeb9ff8427aee6fd83353ca5ffca10d0dc3f6058cf
parent0e9b77d8d08e0270f372f122a6e26d2a95c249c0 (diff)
downloadguix-82cfefc2a04aa43e8444a671ba2cdde171cda032.tar.gz
gnu: guile-dbi: Replace 'url-fetch' by 'git-fetch'.
Fixes https://debbugs.gnu.org/25913.

* gnu/packages/guile-xyz.scm (guile-dbi)[source]: Replace 'url-fetch'
by'git-fetch'.
[home-page]: Update.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 954121c57b..8f83584724 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1456,13 +1456,14 @@ library}.")
     (name "guile-dbi")
     (version "2.1.6")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "http://download.gna.org/guile-dbi/guile-dbi-"
-                    version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://example.org") ;only hosted on Software Heritage
+                    (commit "e19b019e9683faf66c3f385b20fcc112e65f8c6e")))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "116njrprhgrsv1qm904sp3b02rq01fx639r433d657gyhw3x159n"))))
+                "09ys5hj7gnj5w1iv1m194j06jk6b8sdhc8j6hcv3bprq1428kyxw"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags
@@ -1489,7 +1490,7 @@ library}.")
     (propagated-inputs
      `(("guile" ,guile-2.2)))
     (synopsis "Guile database abstraction layer")
-    (home-page "http://home.gna.org/guile-dbi/guile-dbi.html")
+    (home-page "https://web.archive.org/web/20160328232717/http://home.gna.org/guile-dbi/guile-dbi.html")
     (description
      "guile-dbi is a library for Guile that provides a convenient interface to
 SQL databases.  Database programming with guile-dbi is generic in that the same