summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 00:11:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:14 +0200
commit849074f7938d46e323be12d6f6519939b791d40f (patch)
treebce6d9da8cea7409dc0bba17e240cdcfe6242fdf
parenteb4c4b26fa8d76319d858f663273d5eea6cebd3f (diff)
downloadguix-849074f7938d46e323be12d6f6519939b791d40f.tar.gz
gnu: texlive-sourcecodepro: Refresh package definition.
* gnu/packages/tex.scm (texlive-sourcecodepro): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-FONTAXES, TEXLIVE-IFTEX, TEXLIVE-MWEIGHTS, TEXLIVE-XKEYVAL.
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 22 insertions, 14 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a0eea5963f..f7ecc6a9ac 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12753,20 +12753,28 @@ use of the fonts in LaTeX (Type 1) and XeLaTeX/LuaLaTeX (OTF).")
 
 (define-public texlive-sourcecodepro
   (package
-    (inherit (simple-texlive-package
-              "texlive-sourcecodepro"
-              '("/doc/latex/sourcecodepro/"
-                "/fonts/enc/dvips/sourcecodepro/"
-                "/fonts/map/dvips/sourcecodepro/"
-                "/fonts/opentype/adobe/sourcecodepro/"
-                ;; ^ see comment on texlive-sourcesanspro
-                "/fonts/tfm/adobe/sourcecodepro/"
-                "/fonts/type1/adobe/sourcecodepro/"
-                "/fonts/vf/adobe/sourcecodepro/"
-                "/tex/latex/sourcecodepro/")
-              (base32
-               "009v9y7d3vsljgq9nw5yx4kzyqavxbwrlvwhfjj83s6rmb9xcrmh")
-              #:trivial? #t))
+    (name "texlive-sourcecodepro")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/sourcecodepro/"
+                   "fonts/enc/dvips/sourcecodepro/"
+                   "fonts/map/dvips/sourcecodepro/"
+                   "fonts/opentype/adobe/sourcecodepro/"
+                   ;; ^ See comment in `texlive-sourcesanspro'.
+                   "fonts/tfm/adobe/sourcecodepro/"
+                   "fonts/type1/adobe/sourcecodepro/"
+                   "fonts/vf/adobe/sourcecodepro/"
+                   "tex/latex/sourcecodepro/")
+             (base32
+              "009v9y7d3vsljgq9nw5yx4kzyqavxbwrlvwhfjj83s6rmb9xcrmh")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-fontaxes
+           texlive-iftex
+           texlive-mweights
+           texlive-xkeyval))
     (home-page "https://ctan.org/pkg/sourcecodepro")
     (synopsis "Use Source Code Pro with TeX(-alike) systems")
     (description "This package provides the Source Code Pro font family from