summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-20 14:48:47 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-20 18:33:51 +0200
commit8717b34cd42548f6071acfb2f9ed0491b8cc63e1 (patch)
treedefec9261c8cad2351c3072a9218eb399d9c3778
parent40016578118e7733234d85bf3273aa09b9aac1cf (diff)
downloadguix-8717b34cd42548f6071acfb2f9ed0491b8cc63e1.tar.gz
gnu: ocaml4.07-piqi: Fix reference to inputs and output.
The package 'lablgtk@2.8.10' (indirect dependency of ocaml4.07-piqi)
fails to build so this patch could not be tested.

* gnu/packages/ocaml.scm
  (ocaml4.07-piqi)[arguments]<#:make-flags>: Use #$output.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/ocaml.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7385d6e413..e89c1adbb9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3704,9 +3704,10 @@ and 4 (random based) according to RFC 4122.")
     (build-system ocaml-build-system)
     (arguments
      `(#:make-flags
-       (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
-             (string-append "SHELL=" (assoc-ref %build-inputs "bash")
-                            "/bin/sh"))
+       ,#~(list (string-append "DESTDIR=" #$output)
+                (string-append "SHELL="
+                               #+(file-append (canonical-package bash-minimal)
+                                              "/bin/sh")))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'make-files-writable