summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 19:14:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:32 +0200
commit9aa2f5228dc0dcd89bbcb9f7315add7281c18c33 (patch)
treec7ef12383fc17bb857a9dd7b68cea0d39d97c608
parent9ac2e325dd6fd2edb81eaad9f70d84c77de3bf98 (diff)
downloadguix-9aa2f5228dc0dcd89bbcb9f7315add7281c18c33.tar.gz
gnu: texlive-fp: Refresh package definition.
* gnu/packages/tex.scm (texlive-fp): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 86f5a5f3bb..0981fecbe4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11050,13 +11050,17 @@ LaTeX macro support is provided in package @code{psnfss}.")
 
 (define-public texlive-fp
   (package
-    (inherit
-     (simple-texlive-package
-      "texlive-fp"
-      (list "doc/latex/fp/" "tex/latex/fp/" "tex/plain/fp/")
-      (base32 "1q555fx71cf88sn3npzb0j2i10ak920k0qc9ccdygz99vqg10dad")
-      #:trivial? #t))
-    (home-page "https://ctan.org/macros/latex/contrib/fp")
+    (name "texlive-fp")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/fp/" "tex/latex/fp/"
+                   "tex/plain/fp/")
+             (base32
+              "1q555fx71cf88sn3npzb0j2i10ak920k0qc9ccdygz99vqg10dad")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/fp")
     (synopsis "Fixed point arithmetic")
     (description
      "This package provides an extensive collection of arithmetic operations