summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-28 18:43:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-28 18:43:30 +0100
commit9b3df371429e7f5343491dc1bf4c0417389cadd1 (patch)
tree8dbf9decec0084723d8626ce5f4b9d22e89e676a
parentbf1f2122698e37aa796d5446ed9d027b0245730a (diff)
downloadguix-9b3df371429e7f5343491dc1bf4c0417389cadd1.tar.gz
gnu: Add emacs-syslog-mode.
* gnu/packages/emacs-xyz.scm (emacs-syslog-mode): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 50f3929aa4..f020426750 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30176,6 +30176,28 @@ challenge the three computer opponents in one player mode.  You can
 even train opponent slimes.")
     (license license:gpl3+)))
 
+(define-public emacs-syslog-mode
+  (package
+    (name "emacs-syslog-mode")
+    (version "20210910.1952")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/vapniks/syslog-mode.git")
+                    (commit "072664784dae41a573a9de8d178bf577b7526b82")))
+              (sha256
+               (base32
+                "04ddpn6il6mh1f992x3fxl6yljryghi51q4845lx08cbc74wnfz0"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-hide-lines emacs-ov emacs-hsluv))
+    (home-page "https://github.com/vapniks/syslog-mode")
+    (synopsis "Major-mode for viewing log files and strace output")
+    (description "This library provides a major-mode for viewing syslog and
+strace files.  You can highlight and filter the lines of the file by regular
+expressions and by timestamp, view notes associated with files, extract text,
+count matches, etc.")
+    (license license:gpl3+)))
+
 (define-public emacs-systemd-mode
   (package
     (name "emacs-systemd-mode")