summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 14:15:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:33 +0200
commita50776a40c2bc039d95250dfa2ebafddaace60ad (patch)
treef4fed7dc0a05bf9fad70743b6f5247c2fd9c2ad8
parentb45b6210d489b2c77569d2151ba6c7274f887d8d (diff)
downloadguix-a50776a40c2bc039d95250dfa2ebafddaace60ad.tar.gz
gnu: texlive-fvextra: Remove SIMPLE-TEXLIVE-PACKAGE call.
* gnu/packages/tex.scm (texlive-fvextra!): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-ETOOLBOX, TEXLIVE-FANCYVRB, TEXLIVE-LINENO,
TEXLIVE-UPQUOTE.
[description]: Shorten it.
-rw-r--r--gnu/packages/tex.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 870f1d8afb..be84cf0afe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12719,26 +12719,25 @@ to be set left/right or alternating on even/odd pages.")
     (license license:lppl1.3+)))
 
 (define-public texlive-fvextra
-  (let ((template (simple-texlive-package
-                   "texlive-fvextra"
-                   (list "/doc/latex/fvextra/"
-                         "/source/latex/fvextra/"
-                         "/tex/latex/fvextra/")
-                   (base32
-                    "0nawx1fh55yhqspy5jgss2qmwpqmikfrg7628smk931rph9nq0aa"))))
-    (package
-      (inherit template)
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ #t)
-          "latex/fvextra")))
-      (home-page "https://ctan.org/macros/latex/contrib/fvextra")
-      (synopsis "Extensions and patches for fancyvrb")
-      (description
-       "This package provides several extensions to fancyvrb, including
-automatic line breaking and improved math mode.  It also patches some fancyvrb
-internals.")
-      (license license:lppl1.3+))))
+  (package
+    (name "texlive-fvextra")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/fvextra/" "source/latex/fvextra/"
+                   "tex/latex/fvextra/")
+             (base32
+              "0nawx1fh55yhqspy5jgss2qmwpqmikfrg7628smk931rph9nq0aa")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-etoolbox texlive-fancyvrb texlive-lineno texlive-upquote))
+    (home-page "https://ctan.org/pkg/fvextra")
+    (synopsis "Extensions and patches for @code{fancyvrb}")
+    (description
+     "This package provides several extensions to fancyvrb, including
+automatic line breaking and improved math mode.")
+    (license license:lppl1.3+)))
 
 (define-public bibtool
   (package