summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 12:48:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:23 +0200
commita5dba2ee3afb89c18c5e7073f5b9da553cf9a2d1 (patch)
tree961d6119933c85cd576d80e0fdfd96c517a3d080
parent39517adc4872d08ef3d9bcf51e6c4f67cd4d2208 (diff)
downloadguix-a5dba2ee3afb89c18c5e7073f5b9da553cf9a2d1.tar.gz
gnu: texlive-apacite: Refresh package definition.
* gnu/packages/tex.scm (texlive-apacite): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c7ff1a5e99..13804ab139 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12140,25 +12140,27 @@ maintained).")
 
 (define-public texlive-apacite
   (package
-    (inherit (simple-texlive-package
-              "texlive-apacite"
-              (list "tex/latex/apacite/")
-              (base32
-               "0bcfpcmflhvxwzmdj8dgf43mzaywx2asahp52nqn3wwvq64bqym6")
-              #:trivial? #t))
-    (propagated-inputs (list texlive-natbib
-                             texlive-tools))
-    (home-page "https://www.ctan.org/pkg/apacite")
+    (name "texlive-apacite")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/apacite/" "doc/bibtex/apacite/"
+                   "source/bibtex/apacite/" "tex/latex/apacite/")
+             (base32
+              "0nc86zngk71xpbinrfm8p0413xphc0v86ddhcw94gi2sl00hsmzq")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-natbib
+           texlive-tools))
+    (home-page "https://ctan.org/pkg/apacite")
     (synopsis "Citation style following the rules of the APA")
-    (description "Apacite provides a BibTeX style and a LaTeX package which
-are designed to match the requirements of the American Psychological
-Association’s style for citations.  The package follows the 6th edition
-of the APA manual, and is designed to work with the apa6 class.  A test
-document is provided.  The package is compatible with chapterbib and
-(to some extent) with hyperref (for limits of compatibility, see the
-documentation).  The package also includes a means of generating an author
-index for a document.")
-    (license license:lppl1.3+)))
+    (description
+     "Apacite provides a BibTeX style and a LaTeX package which are designed
+to match the requirements of the American Psychological Association's style
+for citations.  The package follows the 6th edition of the APA manual, and is
+designed to work with the @code{apa6} class.")
+    (license license:lppl)))
 
 (define-public texlive-endfloat
   (package