summary refs log tree commit diff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-17 18:32:41 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-01 17:56:00 +0200
commita70372b4aa3108d08841c713d150c5a8029f7c62 (patch)
tree2094e952770fb9d78e7632b6af567f65520bf6fe
parent95a216c4f03d2d71e1bba5776bc5bb719c6969a2 (diff)
downloadguix-a70372b4aa3108d08841c713d150c5a8029f7c62.tar.gz
gnu: blueprint-compiler: Wrap GUIX_PYTHONPATH and GI_TYPELIB_PATH.
* gnu/packages/gnome.scm (blueprint-compiler)[arguments]: Add
python-build-system's wrap phase, as well as a phase for GI_TYPELIB_PATH.
-rw-r--r--gnu/packages/gnome.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 992f148ccb..d8b3692b80 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3276,6 +3276,25 @@ the GNOME desktop environment.")
                (base32
                 "0hj7f4xhwjc4x32r3lswwclbw37fw3spy806g4plkmym25hz4ydy"))))
     (build-system meson-build-system)
+    (arguments
+     (list
+      #:imported-modules
+      `(,@%meson-build-system-modules
+        (guix build python-build-system))
+      #:modules
+      `((guix build meson-build-system)
+        ((guix build python-build-system) #:prefix python:)
+        (guix build utils))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'wrap 'wrap-python
+            (assoc-ref python:%standard-phases 'wrap))
+          (add-after 'wrap-python 'wrap-gi
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let ((out               (assoc-ref outputs "out"))
+                    (gi-typelib-path   (getenv "GI_TYPELIB_PATH")))
+                (wrap-program (string-append out "/bin/blueprint-compiler")
+                  `("GI_TYPELIB_PATH" ":" suffix (,gi-typelib-path)))))))))
     (native-inputs (list gtk python-pygobject python))
     (inputs (list python))
     (synopsis "Template markup language")