summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-20 08:51:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:46:07 -0400
commitab36b88b1a67059a9ea5a3c1c6b5db6563c962cc (patch)
treeb26e980d9c10d77588ff7a0547fc859bf6715509
parente56ff456000155d8ecaf61b1a9af8ac93bda7eb4 (diff)
downloadguix-ab36b88b1a67059a9ea5a3c1c6b5db6563c962cc.tar.gz
gnu: python2-sqlalchemy: Skip a failing test.
* gnu/packages/databases.scm (python2-sqlalchemy)[phases]{check}: Skip the
test_fixture_five test.
-rw-r--r--gnu/packages/databases.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ac3ecbfef1..feedfe68e7 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3371,7 +3371,12 @@ simple and Pythonic domain language.")
                     (invoke "pytest" "-vv"
                             ;; The memory usage tests are very expensive and run in
                             ;; sequence; skip them.
-                            "-k" "not test_memusage.py"))))))))
+                            "-k"
+                            (string-append
+                             "not test_memusage.py"
+                             ;; This test fails with "AssertionError: Warnings
+                             ;; were not seen [...]".
+                             " and not test_fixture_five")))))))))
       ;; Do not use pytest-xdist, which is broken for Python 2.
       (native-inputs (modify-inputs (package-native-inputs base)
                        (delete "python-pytest-xdist"))))))