summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 15:49:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:47 +0200
commitab6566e6a1c3c344487af7d55b35a23df7ce9c03 (patch)
tree3eb0e1076b3156e559093e98780dff61453751e6
parent6539f4e8cddab59283d638b41b4fea550b3258c8 (diff)
downloadguix-ab6566e6a1c3c344487af7d55b35a23df7ce9c03.tar.gz
gnu: texlive-latex-footmisc -> texlive-footmisc.
* gnu/packages/tex.scm (texlive-footmisc): New variable.
(texlive-latex-footmisc): Deprecate variable.
(texlive-latex-xkeyval):
* gnu/packages/docbook.scm (dblatex): Use new name.
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/tex.scm40
2 files changed, 22 insertions, 20 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 4ccae3f252..8134191e38 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -544,7 +544,7 @@ the in DocBook SGML DTDs.")
                                              texlive-fancyhdr
                                              texlive-fancyvrb
                                              texlive-latex-float
-                                             texlive-latex-footmisc
+                                             texlive-footmisc
                                              texlive-hyperref
                                              texlive-latex-jknapltx
                                              texlive-listings
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c17fcf8100..056a4f8a32 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6694,20 +6694,20 @@ the obsolete @code{here} package.  You can select this as automatic default
 with @code{\\floatplacement{figure}{H}}.")
     (license license:lppl)))
 
-(define-public texlive-latex-footmisc
+(define-public texlive-footmisc
   (package
-    (name "texlive-latex-footmisc")
+    (name "texlive-footmisc")
     (version (number->string %texlive-revision))
-    (source (origin
-              (method svn-fetch)
-              (uri (texlive-ref "latex" "footmisc"))
-              (file-name (string-append name "-" version "-checkout"))
-              (sha256
-               (base32
-                "03x61wwql8nh6zrqiiiq3rb0x7m3pn48c606zapy19y21fybwdxs"))))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/footmisc/"
+                   "source/latex/footmisc/"
+                   "tex/latex/footmisc/")
+             (base32
+              "1v1hkf0xcq6hyz3b32z3hvs53lmwrnkn79y9wxq6pqmhcgilqji3")))
+    (outputs '("out" "doc"))
     (build-system texlive-build-system)
-    (arguments '(#:tex-directory "latex/footmisc"))
-    (home-page "https://www.ctan.org/pkg/footmisc")
+    (home-page "https://ctan.org/pkg/footmisc")
     (synopsis "Range of footnote options")
     (description
      "This is a collection of ways to change the typesetting of footnotes.
@@ -6718,6 +6718,8 @@ the same place.  The package also has a range of techniques for labelling
 footnotes with symbols rather than numbers.")
     (license license:lppl1.3+)))
 
+(define-deprecated-package texlive-latex-footmisc texlive-footmisc)
+
 (define-public texlive-letltxmacro
   (let ((template (simple-texlive-package
                    "texlive-letltxmacro"
@@ -10382,19 +10384,19 @@ environments, as well as the @code{array} environment in maths mode.")
                            "xkvutils.tex"))
                #t))))))
     (native-inputs
-     (list texlive-latex-base
-           texlive-cm
-           texlive-lm
-           texlive-url
+     (list texlive-cm
+           texlive-footmisc
            texlive-graphics-def
-           texlive-xcolor
-           texlive-latex-footmisc
            texlive-iftex
+           texlive-latex-base
            texlive-listings
-           texlive-pstricks
+           texlive-lm
+           texlive-pgf
            texlive-pst-text
+           texlive-pstricks
            texlive-tools
-           texlive-pgf))
+           texlive-url
+           texlive-xcolor))
     (home-page "http://www.ctan.org/pkg/xkeyval")
     (synopsis "Extension of the keyval package")
     (description