summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 11:49:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:01 +0200
commitb14d5db8e144c5b11b4e0d204929fb1209bf7eee (patch)
tree64596604910879f106bb557a23e456bbdc8a4924
parentb6ad756412fd5da6d9e0e8d16b969e4c27092106 (diff)
downloadguix-b14d5db8e144c5b11b4e0d204929fb1209bf7eee.tar.gz
gnu: texlive-latex-changepage -> texlive-changepage.
* gnu/packages/tex.scm (texlive-changepage): New variable.
(texlive-latex-changepage): Deprecate variable.
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e37577d80d..908ede3b5a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9240,33 +9240,35 @@ bottom of the page, a new page will be started.")
 
 (define-deprecated-package texlive-latex-needspace texlive-needspace)
 
-(define-public texlive-latex-changepage
+(define-public texlive-changepage
   (package
-    (name "texlive-latex-changepage")
+    (name "texlive-changepage")
     (version (number->string %texlive-revision))
-    (source
-     (origin
-       (method svn-fetch)
-       (uri (texlive-ref "latex" "changepage"))
-       (file-name (string-append name "-" version "-checkout"))
-       (sha256
-        (base32
-         "1rpw8xg5p4jsyh236jma9dz3l29wjx4062f154b3wak5yjcxyxyb"))))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/changepage/"
+                   "source/latex/changepage/"
+                   "tex/latex/changepage/")
+             (base32
+              "0g9zlbqrgxh3p2vys2s84i8v590qi4fbpppp5lkaqc1di8kw60lm")))
+    (outputs '("out" "doc"))
     (build-system texlive-build-system)
     (arguments
-     '(#:tex-directory "latex/changepage"
-       #:tex-format "latex"))
-    (inputs
+     (list #:tex-format "latex"))
+    (native-inputs
      (list texlive-filecontents))
-    (home-page "https://www.ctan.org/pkg/changepage")
+    (home-page "https://ctan.org/pkg/changepage")
     (synopsis "Margin adjustment and detection of odd/even pages")
     (description
      "The package provides commands to change the page layout in the middle of
-a document, and to robustly check for typesetting on odd or even pages.
-Instructions for use are at the end of the file.  The package is an extraction
-of code from the @code{memoir} class, whose user interface it shares.")
+a document, and to robustly check for typesetting on odd or even pages.  The
+package is an extraction of code from the @code{memoir} class, whose user
+interface it shares.  This package will eventually replace the @code{chngpage}
+package, which is distributed with the package.")
     (license license:lppl1.3+)))
 
+(define-deprecated-package texlive-latex-changepage texlive-changepage)
+
 (define-public texlive-latex-eukdate
   (package
     (name "texlive-latex-eukdate")