summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 00:31:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:17 +0200
commitba4df33577eca7b9ac45fe39f9c2aeab574598fc (patch)
tree660314dfb95be93f7e362c1e107319ee77e1b95d
parente47494e51a7545faa7b49934c437b353f460de02 (diff)
downloadguix-ba4df33577eca7b9ac45fe39f9c2aeab574598fc.tar.gz
gnu: texlive-ltablex: Refresh package definition.
* gnu/packages/tex.scm (texlive-ltablex): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-TOOLS.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 65e00f8d8e..2d5751a2ba 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12421,18 +12421,23 @@ non-LaTeX users.")
 
 (define-public texlive-ltablex
   (package
-    (inherit
-     (simple-texlive-package
-      "texlive-ltablex"
-      (list "doc/latex/ltablex/" "tex/latex/ltablex/")
-      (base32 "14lmgj820j6zwj1xnd6ad38kzb9w132kp7sp55cv5bk9vhx3621w")
-      #:trivial? #t))
+    (name "texlive-ltablex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ltablex/" "tex/latex/ltablex/")
+             (base32
+              "14lmgj820j6zwj1xnd6ad38kzb9w132kp7sp55cv5bk9vhx3621w")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-tools))
     (home-page "https://ctan.org/pkg/ltablex")
     (synopsis "Table package extensions")
     (description
      "The @code{ltablex} package modifies the @code{tabularx} environment to
-combine the features of the @code{tabularx} package (auto-sized columns in a
-fixed-width table) with those of the @code{longtable} package (multi-page
+combine the features of the @code{tabularx} package (auto-sized columns in
+a fixed-width table) with those of the @code{longtable} package (multi-page
 tables).")
     (license license:lppl)))